您的位置 首页 行业资讯

【通达信指标】《黄金分割优化量》源码

通达信指标源码《黄金分割优化量》
DRAWRECTREL(0,0,1000,990,RGB(0,55,55));
DRAWRECTREL(0,189,1000,807,RGB(0,55,5));
DRAWRECTREL(0,374,1000,610,RGB(0,5,55));
DRAWRECTREL(0,495,1000,495,RGB(255,00,00));
MT1:=IF(ISLASTBAR,REF((C*2-REF(C,3)),1),DRAWNULL);
MT2:=IF(ISLASTBAR,REF((C*2-REF(C,3)),2),DRAWNULL);
MT3:=IF(ISLASTBAR,C*2-REF(C,3),DRAWNULL);
换手:VOL/CAPITAL*100,POINTDOT COLORMAGENTA;
五日换手:SUM(换手,5),COLORGRAY;
十日换手:SUM(换手,10),COLORGREEN;
DRAWBAND(MA(VOL,5),RGB(155,50,50),MA(VOL,20),RGB(83,123,68));
WOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,WOL,0,3,-1),COLORRED;
VOLUME:VOL,VOLSTICK;V5:MA(VOLUME,5);V10:MA(VOLUME,10);
V20:MA(VOLUME,20); VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主卖:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLORYELLOW,POINTDOT;
倍量柱:=V/REF(V,1)>1.89;
STICKLINE(倍量柱 AND C>O,V,V/2,1,0)COLORYELLOW;
N1:=21;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:IF(SAT>1,1,SAT)*100,COLOR00AAFF,NODRAW;
中点:=REFDATE(HHV(V,180)*0.5,DATE);
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00AAFF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0077FF;
DRAWTEXT(CURRBARSCOUNT=N1+3,中点*1.8,’饱和度’),COLORYELLOW;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长期线:=A+100;
短期线:=B+100;
中期线:=D+100;
见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线));
顶部区域:=(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4;
顶部:=FILTER(顶部区域,4);
STICKLINE( {见顶 OR} 顶部,VOL,VOL*1.1,20,1 ),COLORRED,LINETHICK2;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
STICKLINE( CROSS(84,VAR7),VOL,VOL*1.05,20,1 ),COLORCC7700,LINETHICK2;
顶:=HHV(V,120);
底:=LLV(V,120);
H19:=底+(顶-底)*0.618;
H中:=底+(顶-底)*0.5;
H61:=底+(顶-底)*1.236;
H80:=底+(顶-底)*0.382;
【底】:REFDATE(底,DATE),COLORGREEN;
【0.618】:REFDATE(H19,DATE),COLORYELLOW,POINTDOT;
【0.5】:REFDATE(H中,DATE),COLORWHITE,POINTDOT;
【1.236】:REFDATE(H61,DATE),COLORRED,POINTDOT;
【0.382】:REFDATE(H80,DATE),COLORYELLOW,POINTDOT;
【顶】:REFDATE(顶,DATE),COLORCYAN;

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注